Compiling problems with VS.Net 2003

Problems compiling? Don't understand the source code? Don't know how to code your feature? Post here.

Moderator: Moderators

Locked
Wecks
Posts: 10
Joined: 2005-10-23 09:48

Compiling problems with VS.Net 2003

Post by Wecks » 2005-10-23 10:21

Hi..i've just installed VS.Net 2003 and when i'm trying to compile the project i keep getting this error :
Compiling...
UPnP.cpp
c:\Documents and Settings\WeK\Desktop\DCPlusPlus-0.674-src\windows\UPnP.h(26) : fatal error C1083: Cannot open include file: 'natupnp.h': No such file or directory


Can someone tell me how can i solve this problem ? I'll wait for ur answer .. Thanks !

joakim_tosteberg
Forum Moderator
Posts: 587
Joined: 2003-05-07 02:38
Location: Sweden, Linkoping

Post by joakim_tosteberg » 2005-10-23 10:30

You need to download the platfrom sdk from http://www.microsoft.com/downloads/deta ... laylang=en.
Then you must add the following entries in Settings->Projects->VC++ Directories in vs .net 2003.
Executable files: platfromsdkpath/bin
Include files: platfromsdkpath/include
Library files: platfromsdkpath/lib

Wecks
Posts: 10
Joined: 2005-10-23 09:48

Post by Wecks » 2005-10-23 10:39

joakim_tosteberg.. there are severals programs :PSDK-amd64.exe , PSDK-ia64.exe , PSDK-x86.exe . Which one i need to install ?

Xan1977
Forum Moderator
Posts: 627
Joined: 2003-06-05 20:15

Post by Xan1977 » 2005-10-23 11:24

Wecks wrote:joakim_tosteberg.. there are severals programs :PSDK-amd64.exe , PSDK-ia64.exe , PSDK-x86.exe . Which one i need to install ?

Whichever one pertains to your chipset, presumable x86 if you've got P3 or P4 intel chip.

Or, as compile.txt says: "Since all you need is this one file, you can ask someone at the dev hub to supply it for you (or look for it in the DC++ bugzilla, it's attached to one of the bugs)"

joakim_tosteberg
Forum Moderator
Posts: 587
Joined: 2003-05-07 02:38
Location: Sweden, Linkoping

Post by joakim_tosteberg » 2005-10-23 13:09

Xan1977 wrote:Or, as compile.txt says: "Since all you need is this one file, you can ask someone at the dev hub to supply it for you (or look for it in the DC++ bugzilla, it's attached to one of the bugs)"
It is always good to have the full SDK, you never know when you will need it..... :lol:

Xan1977
Forum Moderator
Posts: 627
Joined: 2003-06-05 20:15

Post by Xan1977 » 2005-10-23 13:13

:) Very true.

Wecks
Posts: 10
Joined: 2005-10-23 09:48

Post by Wecks » 2005-10-23 23:54

Thanks ...i , finally , managed to compile it !! Thanks !! I couldn't install SDK platform (i tried several times to install it but i get an error during the installation
. ) I've downloaded the 'natupnp.h' file ! :P

Carraya
Posts: 112
Joined: 2004-09-21 11:43

Post by Carraya » 2005-10-24 03:02

Wecks wrote:Thanks ...i , finally , managed to compile it !! Thanks !! I couldn't install SDK platform (i tried several times to install it but i get an error during the installation
. ) I've downloaded the 'natupnp.h' file ! :P


Now that is a bad idea, you should rather find out why you can't install platform SDK...
<random funny comment>

joakim_tosteberg
Forum Moderator
Posts: 587
Joined: 2003-05-07 02:38
Location: Sweden, Linkoping

Post by joakim_tosteberg » 2005-10-24 11:11

Wecks wrote:Thanks ...i , finally , managed to compile it !! Thanks !! I couldn't install SDK platform (i tried several times to install it but i get an error during the installation
. ) I've downloaded the 'natupnp.h' file ! :P
Exactly what error do you get?

Wecks
Posts: 10
Joined: 2005-10-23 09:48

Post by Wecks » 2005-10-25 09:55

Well... during the SDK platform installation i (every time i try to install it) get this message:
Error 1606. Could not access network location http://download.microsoft.com/download/ ... mmon.1.cab.

Even if i retry the installation i get this message again ...! I don't know what should i do ! :(
Maybe u can help me ! Thanks !

bastya_elvtars
Posts: 164
Joined: 2005-01-06 08:39
Location: HU
Contact:

Post by bastya_elvtars » 2005-10-25 12:29

404
Hey you, / Don't help them to bury the light... / Don't give in / Without a fight. (Pink Floyd)

joakim_tosteberg
Forum Moderator
Posts: 587
Joined: 2003-05-07 02:38
Location: Sweden, Linkoping

Post by joakim_tosteberg » 2005-10-25 14:04

Wecks wrote:Well... during the SDK platform installation i (every time i try to install it) get this message:
Error 1606. Could not access network location http://download.microsoft.com/download/ ... mmon.1.cab.

Even if i retry the installation i get this message again ...! I don't know what should i do ! :(
Maybe u can help me ! Thanks !
Is the extra dot at the end of the link just an error on you part or is it actually included in the real link? Because if I remove it the link works perfectly.
Check so that you don't have any software firewall which might block the installer from downloading the neccesary files.

bastya_elvtars
Posts: 164
Joined: 2005-01-06 08:39
Location: HU
Contact:

Post by bastya_elvtars » 2005-10-25 15:26

bastya_elvtars wrote:404


/me stupid
Hey you, / Don't help them to bury the light... / Don't give in / Without a fight. (Pink Floyd)

Wecks
Posts: 10
Joined: 2005-10-23 09:48

Post by Wecks » 2005-10-26 05:04

joakim_tosteverg wrote:
Is the extra dot at the end of the link just an error on you part or is it actually included in the real link? Because if I remove it the link works perfectly.
Check so that you don't have any software firewall which might block the installer from downloading the neccesary files.

Yes Joakim , it is included in the real link ....:((

Wecks
Posts: 10
Joined: 2005-10-23 09:48

Post by Wecks » 2005-10-26 05:24

Joakim ... do u think it works if i download that file manually ?

GargoyleMT
DC++ Contributor
Posts: 3212
Joined: 2003-01-07 21:46
Location: .pa.us

Post by GargoyleMT » 2005-10-26 07:47

What you have gone through is a lot more work than locating bug 127 in bugzilla and installing the header files to the appropriate place (which is the same directory as the other SDK UPnP includes.)

Wecks
Posts: 10
Joined: 2005-10-23 09:48

Post by Wecks » 2005-10-26 12:28

Hi guys... do u have any ideea how can i fix this ?
------ Build started: Project: client, Configuration: Debug Win32 ------

Performing Pre-Build Event...
The system cannot find the path specified.
Project : error PRJ0019: A tool returned an error code from "Performing Pre-Build Event..."
(and also)
Linking...
LINK : fatal error LNK1104: cannot open file '.\vc7\Debug\client\client.lib'


Thanks.. for helping me !

joakim_tosteberg
Forum Moderator
Posts: 587
Joined: 2003-05-07 02:38
Location: Sweden, Linkoping

Post by joakim_tosteberg » 2005-10-27 02:00

Could be that you are missing Python needed to generrate Stringdefs.cpp and Example.xml

Compile.txt wrote:Note 5; You need to have python installed if you change StringDefs.h, as a small python script is automatically
run to generate StringDefs.cpp and Example.xml. To turn it off or change python path, go to
client->Header Files->StringDefs.h->Properties->Custom build step and change the appropriate values.
The help file's changelog.html is also updated via a python script (courtesy of fusbar).

Wecks
Posts: 10
Joined: 2005-10-23 09:48

Post by Wecks » 2005-10-27 05:25

Joakim it's ok this version of python ? .. can i install it ?
# Python 2.4.2 Windows installer (Windows binary -- does not include source)

ullner
Forum Moderator
Posts: 333
Joined: 2004-09-10 11:00
Contact:

Post by ullner » 2005-10-27 06:05

WTL or STLport (I can never remember which) isn't properly included.

Wecks
Posts: 10
Joined: 2005-10-23 09:48

Post by Wecks » 2005-10-27 06:11

what do i have to do to include wtl and stlport the proper way , so i don't get all time these errors ? :(

GargoyleMT
DC++ Contributor
Posts: 3212
Joined: 2003-01-07 21:46
Location: .pa.us

Post by GargoyleMT » 2005-10-27 08:57

Just read compile.txt and follow the instructions.

You're Romanian, aren't you?

PseudonympH
Forum Moderator
Posts: 366
Joined: 2004-03-06 02:46

Post by PseudonympH » 2005-10-27 20:03


Locked