dc++ 0.401 users

Use this forum to flesh out your feature request before you enter it in <a href="http://dcpp.net/bugzilla/">Bugzilla</a>.

Moderator: Moderators

Locked
Pict
Posts: 3
Joined: 2006-07-27 09:19

dc++ 0.401 users

Post by Pict » 2006-07-27 09:23

It seems to me that since dc++ versions 0.68x and newer are unable to download from version 0.401, more and more people are downgrading to that version to avoid uploads. I propose that in the next version of dc++ you make it so that it refuses connection attempts from users using version 0.401. It is only fair that they should not be able to download from the new versions since the new versions cant download from them, especially when people speculate in it and downgrade for the sole purpose of avoiding uploads.

Cheers

ivulfusbar
Posts: 506
Joined: 2003-01-03 07:33

Post by ivulfusbar » 2006-07-27 10:03

This is more of a hub.rule issue than a client-issue.
Everyone is supposed to download from the hubs, - I don´t know why, but I never do anymore.

Pict
Posts: 3
Joined: 2006-07-27 09:19

Post by Pict » 2006-07-27 10:07

ivulfusbar wrote:This is more of a hub.rule issue than a client-issue.


Well I disagree. At least it should be an option in the client to block those versions.. just cause a certain hub might allow them, doesnt mean I want to give my bandwidth to those leeches.

TheParanoidOne
Forum Moderator
Posts: 1420
Joined: 2003-04-22 14:37

Post by TheParanoidOne » 2006-07-27 10:57

Deliberate blocking of certain clients seems like something that would be open to abuse.
The world is coming to an end. Please log off.

DC++ Guide | Words

Pict
Posts: 3
Joined: 2006-07-27 09:19

Post by Pict » 2006-07-27 11:05

TheParanoidOne wrote:Deliberate blocking of certain clients seems like something that would be open to abuse.


And deliberate downgrading to a certain version to avoid uploads isnt a form of abuse?

Todi
Forum Moderator
Posts: 699
Joined: 2003-03-04 12:16
Contact:

Post by Todi » 2006-07-27 11:41

Stay in hubs that stop this kind of abuse then. It's easily handled hubwise after all, so if the hub operators don't ban that version, you should express your discontent with them.

Big Muscle
Posts: 72
Joined: 2004-01-23 14:45

Post by Big Muscle » 2006-07-27 13:11

btw, just a suggestion...
DC++ 0.401 has a bug in $UGetBlock implementation that it disconnects requirements for -1 bytes, but why just not use standard protocol command $Get to get filelist from .401 ?

I know that .401 is very old and all users should upgrade, so it was only suggestion ;)

GargoyleMT
DC++ Contributor
Posts: 3212
Joined: 2003-01-07 21:46
Location: .pa.us

Post by GargoyleMT » 2006-08-14 19:09

Sidenote: you can download from 0.401 users, you just can't get their file list.

Big Muscle wrote:DC++ 0.401 has a bug in $UGetBlock implementation that it disconnects requirements for -1 bytes, but why just not use standard protocol command $Get to get filelist from .401 ?

Why work around a bug in an old client, specifically when it doesn't support the feature that you want to promote (TTHL)?

Quattro
Posts: 166
Joined: 2006-01-11 09:23

Post by Quattro » 2006-08-15 02:13

the problem is that most hubs won't block 0.401 untill the normal users stop using dcdm, i will try to force people to use another client, but not to the cost of losing lots and lots of users...
You can send a message around the world in 1/7 of a second; yet it may take several years to move a simple idea through a 1/4 inch of human skull.

Locked