"Max upload speed"

Use this forum to flesh out your feature request before you enter it in <a href="http://dcpp.net/bugzilla/">Bugzilla</a>.

Moderator: Moderators

Locked
Pothead
Posts: 223
Joined: 2005-01-15 06:55

"Max upload speed"

Post by Pothead » 2006-01-20 08:27

This seems to be causing confusion amongst some people who think this is an actual upload limiter . . . :roll:

Would it be better to replace this:
SETTINGS_UPLOAD_SPEED, // "Max upload speed"

with:
SETTINGS_UPLOAD_SPEED, // "Line speed (upload)"

or sommit like that to make it easier to understand. :?:

GargoyleMT
DC++ Contributor
Posts: 3212
Joined: 2003-01-07 21:46
Location: .pa.us

Post by GargoyleMT » 2006-01-20 12:12

That seems sane to me.

Pothead
Posts: 223
Joined: 2005-01-15 06:55

Post by Pothead » 2006-01-29 10:03

For changing this, should i only change the StringDef, or also the Strigdef call (SETTINGS_UPLOAD_SPEED) and the IDC controls ?

Quattro
Posts: 166
Joined: 2006-01-11 09:23

Post by Quattro » 2006-01-29 10:07

you can't figure that out on yourself? ;-) =)
You can send a message around the world in 1/7 of a second; yet it may take several years to move a simple idea through a 1/4 inch of human skull.

ullner
Forum Moderator
Posts: 333
Joined: 2004-09-10 11:00
Contact:

Post by ullner » 2006-01-29 10:15

If you just want to change what DC++ display - The StringDef.

Pothead
Posts: 223
Joined: 2005-01-15 06:55

Post by Pothead » 2006-01-29 11:09

Yes, i just meant should i change the other things which are related to this as well. E.g.
IDC_SETTING_MAX_UPLOAD to IDC_SETTING_LINE_SPEED
to make it easier to follow. I was originally thinking of just the stringdef change, but that makes the rest look untidy.

GargoyleMT
DC++ Contributor
Posts: 3212
Joined: 2003-01-07 21:46
Location: .pa.us

Post by GargoyleMT » 2006-01-30 12:02

Pothead wrote:Yes, i just meant should i change the other things which are related to this as well. E.g.
IDC_SETTING_MAX_UPLOAD to IDC_SETTING_LINE_SPEED
to make it easier to follow. I was originally thinking of just the stringdef change, but that makes the rest look untidy.

Your gut instinct is right. Make the change everywhere it makes sense (this is why I've started using the idc_* as the label for text items in the resource editor, so I don't have to change that string as well.)

Pothead
Posts: 223
Joined: 2005-01-15 06:55

Post by Pothead » 2006-01-30 14:19


Locked