DCH++ 0.34 Problem...

DCH++ has been abandoned, this forum serves mainly as an archive

Moderator: Moderators

Locked
CruL_
Posts: 3
Joined: 2005-01-14 08:19

DCH++ 0.34 Problem...

Post by CruL_ » 2005-01-20 12:47

Hi...

In the 0.34 DCH++ I can't use the client version checking so I can't limit the DC versions over 0.401... First I checked my settings but it looks like perfect, but the check doesn't work.

I had a problem with the hublist registration, but I think it happend becouse the hublist server don't likes dch++, so I installed the hublistpingerhelper script, but it doesn't works, so I don't know what can I do.

In the 0.33 DCH++ this part works perfectly. I think it's only a little bug in this new version.

Please write some advice about this problem, becouse I worked on it a lot of nights but I can't understand.

Sorry for my english... :)

Thx

GargoyleMT
DC++ Contributor
Posts: 3212
Joined: 2003-01-07 21:46
Location: .pa.us

Re: DCH++ 0.34 Problem...

Post by GargoyleMT » 2005-01-20 14:06

CruL_ wrote:In the 0.34 DCH++ I can't use the client version checking so I can't limit the DC versions over 0.401...

Limiting clients to that version, or limiting that version from joining?


As an aside, I thought 0.33 and 0.34 were private beta releases, and that the DCH++ in subversion had a different version tag.

CruL_
Posts: 3
Joined: 2005-01-14 08:19

Post by CruL_ » 2005-01-20 15:12

Hi...

Only over 0.401 could connect to the hub, so 0.306 could not.

<DescriptionChecking Enabled="1">
<!-- do we deny tagged client which we do not know? 0 / 1 -->
<DenyUnknownClients>0</DenyUnknownClients>
<!-- do we force clients to have a tag? 0 / 1 -->
<ForceUseOfTag>1</ForceUseOfTag>

<!-- DC++ minversion (-1=disallow) -->
<DcppMinVersion>0.401</DcppMinVersion>
<!-- DCGUI minversion (-1=disallow, write 0.2.5 as 0.0205) -->
<DcguiMinVersion>0.0300</DcguiMinVersion>
<!-- NMDC minversion (-1=disallow, tags exist since v2.01) -->
<NmdcMinVersion>-1</NmdcMinVersion>
<!-- QuickDC minversion (-1=disallow) -->
<QuickdcMinVersion>-1</QuickdcMinVersion>
<!-- DC:PRO minversion (-1=disallow, write 0.2.5.4 as 0.0205) -->
<DcproMinVersion>-1</DcproMinVersion>
<!-- oDC minversion (-1=disallow, works only for >= 5.22 versions which use <oDC V:..) -->
<OdcMinVersion>0</OdcMinVersion>

<!-- max number of hubs (H:) -->
<MaxHubs>20</MaxHubs>
<!-- how to count the number of hubs: 0=x, 1=x/y, 2=x/y/z -->
<HubCountMethod>1</HubCountMethod>
<!-- slots (S:) -->
<MinSlots>0</MinSlots>
<MaxSlots>100</MaxSlots>
<MinSlotsPerHub>0</MinSlotsPerHub>
<!-- max for "open extra slot if speed is below X" (O:) -->
<MaxUpload>0</MaxUpload>
<!-- bandwidth limiting in kB/s (U:/L:/B:/F:) (-1=disallow) -->
<MinUploadLimit>8</MinUploadLimit>
</DescriptionChecking>



This is the config...

Locked